Corrigindo problema do Acrobat Reader 7.0.9 no Ubuntu Feisty Fawn


Após atualizar meu Ubuntu Feisty Fawn não havia reparado ainda que meu acroread havia parado de funcionar, não lei mais coisas no computador, mas houve um dia que baixei o cups-pdf e gerei alguns PDF’s, quando fui testar qual não foi minha surpresa, meu acroread não dava nem sinal de vida, espera aí, sinal ele dava sim, quando executei-o em um terminal tive a seguinte mensagem:

expr: syntax error

Não liguei muito, comecei a usar o ‘Visualizador de Documentos’, mas o que ocorre é que o acroread começou a fazer falta e eu então me dispus a pesquisar em fóruns da Adobe pelo possível erro, mas nada de informação, foi uma ‘caça’ difícil, mas encontrei pessoas que tinham em comum comigo este erro, pois então uni informações de alguns fóruns e resolvi o problema.

Para tal faça da seguinte forma:

Entre no link abaixo e faça o download da LIB libgtk2.0-0_2.10.11-0ubuntu3_i386.deb:

Em seguida mova-a para o diretório /usr, vá para lá também fazendo uso de um terminal, passe o comando:

# dpkg -x libgtk2.0-0_2.10.11-0ubuntu3_i386.deb libgtk2

Em seguida edite o script acroread:

$ sudo gedit `which acroread`

E adicione e substitua as seguintes linhas no arquivo:

#!/bin/sh
#
LC_NUMERIC=C
export LC_NUMERIC
export GTK_IM_MODULE=xim
export LD_PRELOAD=/usr/libgtk2/usr/lib/libgtk-x11-2.0.so.0.1000.11

setLangENU()
{

Em seguida encontre e comente a linha abaixo no script:

check_gtk_ver_and_set_lib_path “$MIN_GTK_VERSION” ### returns 0 if found gtk >= 2.4

É isto aí, qualquer coisa estamos aí.

Veja como ficou no screenshot abaixo:

acroread

Lembre-se que já está disponível o Adobe Reader 8 nos repositórios do medibuntu.

Anúncios

,

  1. Deixe um comentário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

  • Follow Carl Roberson's on WordPress.com
  • Fallow me
  • Linux 20 Anos
  • Ubuntu LTS Trusty Tahr

    Lançamento da versão LTS do Ubuntu20 de abril de 2014
    Ubuntu LTS Trusty Tahr Chegou!!! http://www.ubuntu.com/download/desktop
  • Grafica Livre

  • O que estou lendo agora

  • Na minha estante me aguardando


    Literatura
  • Bookmark and Share
%d blogueiros gostam disto: